Diskusi Ibnu Rofik

Ibnu Rofik
Ditanyakan pada: Menggunakan Composer

Pengambilan data faker di browser packages

Halo Ka,

Setelah saya input "composer require fzaninotto/faker" ada notice "Cannot use ..." seperti gambar ini https://pasteboard.co/Zh9ynQ745AGb.png

dan saat menuliskan kode nya muncul error undefined https://pasteboard.co/6lQSB2kb2srn.png

2 Jawaban

Avatar
Muhammad Fakhry Burhanuddin

sebulan yang lalu

Sebagai programmer kita dituntut untuk dapat mengerti sebuah error.

Terjemahan dari error tersebut adalah tidak bisa menggunakan versi terbaru v1.9.2 dari faker karena membutuhkan php versi ^5.3.3 atau ^7.0.

Dilihat dari halaman di packagist.org https://packagist.org/packages/fzaninotto/faker library ini sudah tidak dimaintain.

Untuk tetap dapat mengikuti kelas ini sebaiknya memakai PHP versi 7.

Avatar
BroKoding

sebulan yang lalu

Halo kak, error ini bukanlah error pada code melainkan karena environment dalam hal ini adalah versi PHP. Untuk versi PHP yang digunakan berapa ya kak? Saya coba carikan versi fzaninotto/faker yang sesuai dengan versi PHP yang digunakan.